NOTE: The steps outlined on this page are only applicable if you installed the SDK prior to 2.1.0 with a .netrc file. For current installation steps, please refer to our getting started page.

As part of the Pilgrim 2.1.0 release we made it easier to get the SDK into your iOS project by allowing developers to download the framework through standard iOS dependency managers (Carthage, CocoaPods & manually). The changes to get the SDK integrated for each platform are outlined below:

Carthage

  1. Remove the Pilgrim credentials from the .netrc file.

CocoaPods

  1. Remove the Pilgrim credentials from the .netrc file.
  2. Remove reference to the old foursquare Artifactory repository by removing the following lines from the top of your Podfile.
  1. Run pod repo update to get the latest version of the CocoaPods Spec’s repo (needed so that cocoapods is able to see the Pilgrim podspec)
  2. Install Pilgrim using the instructions outlined on our getting started page.

Note: if you are using any other SDK’s installed using Artifactory, only remove the 'foursquare-internal' line.

Manual Installation

  1. Remove the Pilgrim credentials from the .netrc file.
Was this page helpful?
Yes
No
Thank you!